Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Elgen

Pages: [1] 2 3 ... 7
3
ARCADE / Psychic5 video distortion. Input needed! };-S
« on: March 06, 2013, 07:10:03 PM »
Hey Mates

I currently have a bootleg Psychic5 on the table. I've made some repairs in the controls/input section and made a JAMMA-adaptor, and it now plays perfectly.

HOWEVER, there are some small, tho rather annoying, distortions in the upper part of the screen.
It looks like small white stripes about ½-1cm long (in the direction of the scanlines) and 1pixel wide. They only apear during gameplay (or gameplay-part of the attract-mode), and not all the time.

I've to take 2 stills of it with my iPhone





I've also shot a small video of it

http://www.youtube.com/watch?v=MOPsOnKEqCM

The board is 2 PCBs with ribbons, and video is generated on the secondary PCB. The fault is definitly on the second board, cause I've got another Psychic5 (maby original?) with identical secondary PCB. And if I swap the PCBs, the error swaps as well.

I've traced the R/G/B and SYNC lines back på this section on the secondary board; actually they go directly to some of the resistors



Another piece of info is, that this game can flip the screen via dip switch, and when I do so, the interference still appear in the same physical place on the screen (top); it doesn't flip along with the picture.

I'm pretty sure, that this interference is induced into the video signal during the very last steps of the video generation, as it looks like affects both back grounds and sprites, but that is just my feeling...could be wrong.

This is really starting to annoy me, so any input would be nice.

Also, should anyone have a scan of the schematics for the game, I would be very glad to get a copy; haven't been able to find it via googling.

8
Hi, sorry that I haven't been that good at answering at all the forums...
I thank you all for all the good advise and help I've gotten on the different forums, but just now I actually managed to pull off myself.

I DID have the right ROM-image, I'd just been programming it wrong };-(
I'd used my Top2005+ to program a 2732 (Vpp=21V), and even though the software says it's capable of doing it, it apparently isn't... I'd also tried programming a 2764 (Vpp=12.5V) with the doubled image and then modified it so that the pins would fit the socket (maby I'd done something wrong there, cause that should have actually worked?!), but that didn't work either.

Now tonite I used my old ISA-based Sunshine programmer http://elgensrepairs.blogspot.dk/2012/08/scope-dead-but-new-old-one-acquired.html
(thnx Jarl for donating it to me), and that did the trick using the sq07.108 ROM with CRC32=d11411fb.




So lesson learned. Top2005+ can't be thrusted when programming very old EPROM (with Vpp > 12.5) that ought to be programmed with the classic algorithm (50ms/write).

Again thx all you guys, now I can get on with solving the sprite-problems };-P



...and ofcause I'll post a link to the rep log when it's done.

For reference, here are the links to the threads on the other forums I've posted this problem on:

http://www.dragonslairfans.com/smfor/index.php?topic=4253.msg61395;boardseen#new
http://retrocomputermuseum.co.uk/forum/index.php?topic=4995.msg48773;boardseen#new
http://spille-maskiner.dk/forum/viewtopic.php?f=6&t=12227
http://www.aussiearcade.com.au/showthread.php/56680-Seeking-Bootleg-SuperQIX-not-for-buying-but-for-a-ROM-dump?p=714345#post714345

9
ARCADE / Seeking: Bootleg SuperQIX; not for buying, but for a ROM dump...
« on: February 02, 2013, 11:41:15 AM »
Ok, my problem is this. I was trying to fix a bootleg SuperQIX with sprite errors. During this, I had one of the ROMs out of the socket (and forgot to dumpd it). Now the clown who fitted this socket, had soldered it in backwards. So when I put the ROM back, it was actually reversed resulting in it getting fried. As I didn't have a dump of the ROM, I was basicly screwed. I have tried all the different dumps in MAME, but can't find one that works on my board.

This is how the board looks


and the ROM in question is the one in the upper rigth corner; here's a close-up


The ROM is an 2732. So if you have this board, or one that looks like it, I would be very glad to get a dump of this IC. Otherwise, this board is just for the scrap-pile...

11
ARCADE / Best way to debug a stuck bus line?!
« on: January 26, 2013, 10:40:02 AM »
Okay, here's the situation:
I'm currently working on a bootleg 1942 where the only initial problem was that some of the controller lines was stuck low causing the plane to go left and use all rolls at start-up. That fix was easy: Changed a couple of fried 367's in the input section.
However while working on it, I suddenly lost all sound?! I don't think it's related to the input problem at all, just a coincidence.
The sound CPU is a Z80 controlling 2 AY-3-8910 via the Z80's databus. On the same bus is also an SRAM and the sound ROM. Now one of the 8 lines is stuck low (one right in the middle). That is it fluctuates between GND and 0.5V, so it looks to me like something is trying to drive it. It also have direct contact to GND (used continuity tester). But I can't seem to find the component that's pulling it down. Tried to cut the relevant pins on both the AYs, the ROM (just pulled it from the socket), the RAM, the CPU, and also a 374 I found to be on the bus. I would rather avoid desoldering the CPU and the AYs.
As bonus info I have a working SolomonsKey with 3 of the same sound chips, and here ALL datalines are active.
By the way, the way I tried to find ICs and components that connects to the stuck, is by starting at the AYs and beeping the healthy bus line just besides the stuck one around the PCB and then looking if data pins 'close to' it on the ICs I found were stuck low.

Where would go next? Is it desoldering the AYs and CPU to see how the circuit is under them, or is there more to check before that?

Any help could be useful };-P

13
ARCADE / Re: Starting Arcade repairs
« on: January 13, 2013, 02:56:13 PM »
Having a child once in a while, will put the repairing on hold for some time...but if you've just once felt the rush of a board coming to live, the itching will soon come crawling back...rest assured };-P
Once a repper...

15
ARCADE / Re: Atari Tempest PCB Repair Log
« on: December 29, 2012, 08:10:43 PM »
The Jag-version T2K is one of my (if not THE) All Time Favourites };-P

I love Minters all stuff...

Fantastic save.

Pages: [1] 2 3 ... 7