Topic: Datadynamics (Teledynamics) ZIP-30 teleprinter  (Read 166 times)

Author Message

0 Members and 1 Guest are viewing this topic.

Offline jerryw200

  • ZX80
  • *
  • Posts: 18
  • Kudos 0
    • View Profile
Datadynamics (Teledynamics) ZIP-30 teleprinter
« on: June 17, 2018, 02:42:02 PM »
Hi
I am in the process of restoring a datadynamics ZIP-30 teleprinter.
It had over 100 faults and was in a terrible state when I got it but it is finally getting close to being fully functional but I have a remaining problem that is proving hard to resolve.
The unit has both a paper tape punch and a reader and I have got the punch working fine but I am having a problem with the reader.
It will read single bytes at a time but when I press the read button it just drives to the next sprocket hole and stops. It seems to be waiting for a command to read the next byte but I cannot find the fault.
I have stripped the units and all the sensors work and the buffer amplifiers all work. I have traced all bit signals back to the processor PIA and they are all there except one. The sprocket channel has two sensors which read out of phase and while both signals are getting through the buffer amplifiers I can only find one of these signals at the processor board. The second phase signal goes into some logic on the interface board (which is in the punch) but because of the way the units are constructed it is very difficult to trace the signals any further.
Does anyone have any service data or schematics for a ZIP-30?
Or has anyone come across this issue.
Note that I have tried adjusting the amplifier gain pots for the two channels but this made no difference and I know the data channels are working because the single byte read is reading correct data.
Any help would be appreciated.

Regards
Jerry