Topic: Bizarre C64 fault  (Read 6540 times)

Author Message

0 Members and 1 Guest are viewing this topic.

Offline jack_farmer

  • ZX80
  • *
  • Posts: 37
  • Kudos 2
  • Gender: Male
  • "I'm not anti-social; I'm just not user friendly."
    • View Profile
Bizarre C64 fault
« on: February 14, 2015, 01:38:30 PM »
Hello,

I've just uncovered a new problem with my Commodore 64 (64E). Plugged into my TV via RF, it starts up just fine first time; but if I come to restart it for whatever reason I get a black screen. The C64 must still be powered on, as the red LED lights up, and my TV does not give a 'no signal' screen.  The black screen occasionally flickers, but I really have no idea what is wrong. It just seems to strange since when it does power up it works perfectly.

To get it powering up and working properly again, I have found that just leaving the C64 turned off for a while does the trick; but this is hardly a long-term solution!  :-\

I have cleaned the C64's board, checked for any 'chip creep' and checked for any broken traces or leaky caps; but this hasn't yielded any results. Where do I go from here?

Thanks in advance,
Jack :)

Offline AndyRCM

  • >=))))º> GO FEED THE FISH! <º((((=<
  • Administrator
  • Amiga 4000
  • ******
  • Posts: 9675
  • Kudos 50
  • Gender: Male
  • Manic Jet Set Willy
    • View Profile
    • Retro Computer Museum
Re: Bizarre C64 fault
« Reply #1 on: February 14, 2015, 05:38:57 PM »
I would say the PLA chip is on its way out. :( Expensive to fix - £15+ :(
"I could see the faces of those who led pissing themselves laughing" - Funeral Pyre by The Jam

Offline jack_farmer

  • ZX80
  • *
  • Posts: 37
  • Kudos 2
  • Gender: Male
  • "I'm not anti-social; I'm just not user friendly."
    • View Profile
Re: Bizarre C64 fault
« Reply #2 on: February 14, 2015, 06:53:39 PM »
Fantastic  :'( - is the PLA one of the easily removable chips? If so, I'll just keep an eye out until a working one shows up cheap on eBay.

Thanks Andy :)

Offline AndyRCM

  • >=))))º> GO FEED THE FISH! <º((((=<
  • Administrator
  • Amiga 4000
  • ******
  • Posts: 9675
  • Kudos 50
  • Gender: Male
  • Manic Jet Set Willy
    • View Profile
    • Retro Computer Museum
Re: Bizarre C64 fault
« Reply #3 on: February 14, 2015, 08:44:18 PM »
On some machines the PLA is socketed - on others it isnt. :(

"I could see the faces of those who led pissing themselves laughing" - Funeral Pyre by The Jam

Offline jack_farmer

  • ZX80
  • *
  • Posts: 37
  • Kudos 2
  • Gender: Male
  • "I'm not anti-social; I'm just not user friendly."
    • View Profile
Re: Bizarre C64 fault
« Reply #4 on: February 15, 2015, 12:42:08 AM »
Thanks Andy, will do some more research tomorrow :)

Offline jack_farmer

  • ZX80
  • *
  • Posts: 37
  • Kudos 2
  • Gender: Male
  • "I'm not anti-social; I'm just not user friendly."
    • View Profile
Re: Bizarre C64 fault
« Reply #5 on: February 15, 2015, 01:25:17 PM »
Turns out my PLA is soldered in, so it probably wouldn't be worth trying to remove it and soldering in a new one (at least with my poor soldering skills). I think my plan of action is to find another C64 online (perhaps with a warranty or guarantee) to replace mine; and I'll keep the dead one as a parts machine or something.

Thanks, Jack :)

Offline Panther

  • Committee
  • Amiga 4000
  • *
  • Posts: 4180
  • Kudos 35
  • Gender: Male
  • Look at the size of my.......Paws
    • View Profile
Re: Bizarre C64 fault
« Reply #6 on: February 17, 2015, 10:53:37 AM »
One cheap here

http://www.ebay.co.uk/itm/Commodore-64-/151587848739?pt=LH_DefaultDomain_3&hash=item234b570223

Well cheap at the moment (£!5.00), but will probably go for a lot more  :-\

Offline jack_farmer

  • ZX80
  • *
  • Posts: 37
  • Kudos 2
  • Gender: Male
  • "I'm not anti-social; I'm just not user friendly."
    • View Profile
Re: Bizarre C64 fault
« Reply #7 on: February 17, 2015, 01:48:39 PM »
Thanks for that! I'd love a bread bin, since I have the slimmer (but far less retro-looking) 64C.

Jack :)

Offline AndyRCM

  • >=))))º> GO FEED THE FISH! <º((((=<
  • Administrator
  • Amiga 4000
  • ******
  • Posts: 9675
  • Kudos 50
  • Gender: Male
  • Manic Jet Set Willy
    • View Profile
    • Retro Computer Museum
Re: Bizarre C64 fault
« Reply #8 on: February 17, 2015, 05:29:59 PM »
If you can source a PLA (there are replacements available) . . . we can de-solder your old one and put you in a socket . . . :)

A
"I could see the faces of those who led pissing themselves laughing" - Funeral Pyre by The Jam

Offline jack_farmer

  • ZX80
  • *
  • Posts: 37
  • Kudos 2
  • Gender: Male
  • "I'm not anti-social; I'm just not user friendly."
    • View Profile
Re: Bizarre C64 fault
« Reply #9 on: February 18, 2015, 10:41:24 PM »
Thanks a lot Andy! I'll keep my eye out for cheap PLA's online. It must only be a matter of time before someone puts one on for a fiver  :)

Offline AndyRCM

  • >=))))º> GO FEED THE FISH! <º((((=<
  • Administrator
  • Amiga 4000
  • ******
  • Posts: 9675
  • Kudos 50
  • Gender: Male
  • Manic Jet Set Willy
    • View Profile
    • Retro Computer Museum
Re: Bizarre C64 fault
« Reply #10 on: February 19, 2015, 08:17:05 AM »
These are the ones that we have . . . none left now at RCM or indeed on this website. Hopefully some more will be made. :)

http://www.protovision-online.de/shop/product_info.php?products_id=137&language=en

"I could see the faces of those who led pissing themselves laughing" - Funeral Pyre by The Jam

Offline jack_farmer

  • ZX80
  • *
  • Posts: 37
  • Kudos 2
  • Gender: Male
  • "I'm not anti-social; I'm just not user friendly."
    • View Profile
Re: Bizarre C64 fault
« Reply #11 on: February 19, 2015, 11:44:34 PM »
Fingers crossed!  :)

Offline porchy

  • Moderator
  • Amiga 4000
  • ******
  • Posts: 825
  • Kudos 33
  • Gender: Male
    • View Profile
    • JAMMArcade
Re: Bizarre C64 fault
« Reply #12 on: February 20, 2015, 07:29:59 PM »
The ones I used to get are also no longer available. You could always give the EPROM method a go

Offline porchy

  • Moderator
  • Amiga 4000
  • ******
  • Posts: 825
  • Kudos 33
  • Gender: Male
    • View Profile
    • JAMMArcade
Re: Bizarre C64 fault
« Reply #13 on: February 20, 2015, 07:36:09 PM »
actually, try here.
http://www.sinchai.de/index.php?main_page=product_info&cPath=3&products_id=139

Ive ordered quite a few things from here and they are decent, but they arent too cheap

Offline jack_farmer

  • ZX80
  • *
  • Posts: 37
  • Kudos 2
  • Gender: Male
  • "I'm not anti-social; I'm just not user friendly."
    • View Profile
Re: Bizarre C64 fault
« Reply #14 on: February 20, 2015, 07:54:58 PM »
Thanks guys, I'm just worried that it would end up costing more than another working C64 on eBay  :-\